p PatchFirst

CVE-2009-4214

CVE-2009-4214

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in the strip_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote attackers to inject arbitrary web script or HTML via vectors involving non-printing ASCII characters, related to HTML::Tokenizer and actionpack/lib/action_controller/vendor/html-scanner/html/node.rb.

EPSS 3.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rails Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.2.3-2

    Update to 2.2.3-2

  • rails Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.2.3-2

    Update to 2.2.3-2

  • rails Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.2.3-2

    Update to 2.2.3-2

Original sources

Check your server →