p PatchFirst

CVE-2009-4270

CVE-2009-4270

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Stack-based buffer overflow in the errprintf function in base/gsmisc.c in ghostscript 8.64 through 8.70 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted PDF file, as originally reported for debug logging code in gdevcups.c in the CUPS output driver.

EPSS 6.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ghostscript Debian:12

    Affected ranges
    • ECOSYSTEM: < 8.70~dfsg-2.1

    Update to 8.70~dfsg-2.1

  • ghostscript Debian:13

    Affected ranges
    • ECOSYSTEM: < 8.70~dfsg-2.1

    Update to 8.70~dfsg-2.1

  • ghostscript Debian:14

    Affected ranges
    • ECOSYSTEM: < 8.70~dfsg-2.1

    Update to 8.70~dfsg-2.1

Original sources

Check your server →