p PatchFirst

CVE-2009-5054

CVE-2009-5054

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Smarty before 3.0.0 beta 4 does not consider the umask value when setting the permissions of files, which might allow attackers to bypass intended access restrictions via standard filesystem operations.

EPSS 1.6% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • smarty3 Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.0~rc1-1

    Update to 3.0~rc1-1

  • smarty3 Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.0~rc1-1

    Update to 3.0~rc1-1

  • smarty3 Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.0~rc1-1

    Update to 3.0~rc1-1

  • smarty/smarty Packagist

    Versions
    • v2.6.24
    • v2.6.25
    • v2.6.26
    • v2.6.27
    • v2.6.28
    • v2.6.29
    • v2.6.30
    • v2.6.31
    • v2.6.33
    Affected ranges
    • ECOSYSTEM: < 3.0.0-beta4

    Update to 3.0.0-beta4

Original sources

Check your server →