p PatchFirst

CVE-2010-0304

CVE-2010-0304

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple buffer overflows in the LWRES dissector in Wireshark 0.9.15 through 1.0.10 and 1.2.0 through 1.2.5 allow remote attackers to cause a denial of service (crash) via a malformed packet, as demonstrated using a stack-based buffer overflow to the dissect_getaddrsbyname_request function.

EPSS 74.1% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wireshark Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.2.6-1

    Update to 1.2.6-1

  • wireshark Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.2.6-1

    Update to 1.2.6-1

  • wireshark Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.2.6-1

    Update to 1.2.6-1

Original sources

Check your server →