p PatchFirst

CVE-2010-1614

CVE-2010-1614

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple cross-site scripting (XSS) vulnerabilities in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) the Login-As feature or (2) when the global search feature is enabled, unspecified global search forms in the Global Search Engine. NOTE: vector 1 might be resultant from a cross-site request forgery (CSRF) vulnerability.

CVSS 5.3 · Medium · EPSS 1.7% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • moodle/moodle Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 1.8.0, < 1.8.12

    Update to 1.8.12

  • moodle/moodle Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 1.9.0, < 1.9.8

    Update to 1.9.8

Original sources

Check your server →