p PatchFirst

CVE-2010-1615

CVE-2010-1615

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple SQL injection vulnerabilities in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 allow remote attackers to execute arbitrary SQL commands via vectors related to (1) the add_to_log function in mod/wiki/view.php in the wiki module, or (2) "data validation in some forms elements" related to lib/form/selectgroups.php.

CVSS 9.3 · Critical · EPSS 1.7% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • moodle/moodle Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 1.8.0, < 1.8.12

    Update to 1.8.12

  • moodle/moodle Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 1.9.0, < 1.9.8

    Update to 1.9.8

Original sources

Check your server →