p PatchFirst

CVE-2010-2055

CVE-2010-2055

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Ghostscript 8.71 and earlier reads initialization files from the current working directory, which allows local users to execute arbitrary PostScript commands via a Trojan horse file, related to improper support for the -P- option to the gs program, as demonstrated using gs_init.ps, a different vulnerability than CVE-2010-4820.

EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ghostscript Debian:12

    Affected ranges
    • ECOSYSTEM: < 8.71~dfsg2-6.1

    Update to 8.71~dfsg2-6.1

  • ghostscript Debian:13

    Affected ranges
    • ECOSYSTEM: < 8.71~dfsg2-6.1

    Update to 8.71~dfsg2-6.1

  • ghostscript Debian:14

    Affected ranges
    • ECOSYSTEM: < 8.71~dfsg2-6.1

    Update to 8.71~dfsg2-6.1

Original sources

Check your server →