p PatchFirst

CVE-2010-2230

CVE-2010-2230

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The KSES text cleaning filter in lib/weblib.php in Moodle before 1.8.13 and 1.9.x before 1.9.9 does not properly handle vbscript URIs, which allows remote authenticated users to conduct cross-site scripting (XSS) attacks via HTML input.

EPSS 2.2% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wordpress Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.0.4+dfsg-1

    Update to 3.0.4+dfsg-1

  • wordpress Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.0.4+dfsg-1

    Update to 3.0.4+dfsg-1

  • wordpress Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.0.4+dfsg-1

    Update to 3.0.4+dfsg-1

  • moodle/moodle Packagist

    Affected ranges
    • ECOSYSTEM: < 1.8.13

    Update to 1.8.13

  • moodle/moodle Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 1.9.0, < 1.9.9

    Update to 1.9.9

Original sources

Check your server →