p PatchFirst

CVE-2010-2422

CVE-2010-2422

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in PortalTransforms in Plone 2.1 through 3.3.4 before hotfix 20100612 allows remote attackers to inject arbitrary web script or HTML via the safe_html transform.

CVSS 6.1 · Medium · EPSS 2.0% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • plone PyPI

    Versions
    • 3.2
    • 3.2.1
    • 3.2.2
    • 3.2.3
    • 3.2a1
    • 3.2rc1
    • 3.3
    • 3.3.1
    • 3.3.2
    • 3.3.3
    • 3.3.4
    • 3.3.5
    • 3.3b1
    • 3.3rc1
    • 3.3rc2
    • 3.3rc3
    • 3.3rc4
    • 3.3rc5
    Affected ranges
    • ECOSYSTEM: ≥ 2.1, < 3.3.6

    Update to 3.3.6

  • plone PyPI

    Versions
    • 3.2
    • 3.2.1
    • 3.2.2
    • 3.2.3
    • 3.2a1
    • 3.2rc1
    • 3.3
    • 3.3.1
    • 3.3.2
    • 3.3.3
    • 3.3.4
    • 3.3b1
    • 3.3rc1
    • 3.3rc2
    • 3.3rc3
    • 3.3rc4
    • 3.3rc5
    Affected ranges
    • ECOSYSTEM: < 3.3.5

    Update to 3.3.5

Original sources

Check your server →