p PatchFirst

CVE-2010-2480

CVE-2010-2480

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Mako before 0.3.4 relies on the cgi.escape function in the Python standard library for cross-site scripting (XSS) protection, which makes it easier for remote attackers to conduct XSS attacks via vectors involving single-quote characters and a JavaScript onLoad event handler for a BODY element.

CVSS 6.1 · Medium · EPSS 1.8% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • mako Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.3.4-1

    Update to 0.3.4-1

  • mako Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.3.4-1

    Update to 0.3.4-1

  • mako Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.3.4-1

    Update to 0.3.4-1

  • mako PyPI

    Versions
    • 0.1.0
    • 0.1.1
    • 0.1.10
    • 0.1.2
    • 0.1.3
    • 0.1.4
    • 0.1.5
    • 0.1.6
    • 0.1.7
    • 0.1.8
    • 0.1.9
    • 0.2.0
    • 0.2.1
    • 0.2.2
    • 0.2.3
    • 0.2.4
    • 0.2.5
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.3.3
    Affected ranges
    • ECOSYSTEM: < 0.3.4

    Update to 0.3.4

Original sources

Check your server →