p PatchFirst

CVE-2010-2958

CVE-2010-2958

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in libraries/Error.class.php in phpMyAdmin 3.x before 3.3.6 allows remote attackers to inject arbitrary web script or HTML via vectors related to a PHP backtrace and error messages (aka debugging messages), a different vulnerability than CVE-2010-3056.

EPSS 1.9% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • phpmyadmin Debian:12

    Affected ranges
    • ECOSYSTEM: < 4:3.3.6-1

    Update to 4:3.3.6-1

  • phpmyadmin Debian:13

    Affected ranges
    • ECOSYSTEM: < 4:3.3.6-1

    Update to 4:3.3.6-1

  • phpmyadmin Debian:14

    Affected ranges
    • ECOSYSTEM: < 4:3.3.6-1

    Update to 4:3.3.6-1

  • phpmyadmin/phpmyadmin Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 3.0.0, < 3.3.6

    Update to 3.3.6

Original sources

Check your server →