CVE-2010-3704
CVE-2010-3704
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
The FoFiType1::parse function in fofi/FoFiType1.cc in the PDF parser in xpdf before 3.02pl5, poppler 0.8.7 and possibly other versions up to 0.15.1, kdegraphics, and possibly other products allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via a PDF file with a crafted PostScript Type1 font that contains a negative array index, which bypasses input validation and triggers memory corruption.
EPSS 3.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
poppler Debian:12
- Affected ranges
- ECOSYSTEM: < 0.12.4-1.2
Update to 0.12.4-1.2
poppler Debian:13
- Affected ranges
- ECOSYSTEM: < 0.12.4-1.2
Update to 0.12.4-1.2
poppler Debian:14
- Affected ranges
- ECOSYSTEM: < 0.12.4-1.2
Update to 0.12.4-1.2
xpdf Debian:12
- Affected ranges
- ECOSYSTEM: < 3.02-9
Update to 3.02-9
xpdf Debian:13
- Affected ranges
- ECOSYSTEM: < 3.02-9
Update to 3.02-9
xpdf Debian:14
- Affected ranges
- ECOSYSTEM: < 3.02-9
Update to 3.02-9
ipe Ubuntu:16.04:LTS
- Versions
- 7.1.4-2.1
- 7.1.8-1
- 7.1.10-1
- 7.1.10-1.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ipe Ubuntu:18.04:LTS
- Versions
- 7.2.7-2
- 7.2.7-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ipe Ubuntu:20.04:LTS
- Versions
- 7.2.9-1
- 7.2.13-2
- 7.2.13-2build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ipe Ubuntu:22.04:LTS
- Versions
- 7.2.23+dfsg1-2
- 7.2.24+dfsg1-1
- 7.2.24+dfsg1-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ipe Ubuntu:24.04:LTS
- Versions
- 7.2.27+dfsg1-2
- 7.2.28-2
- 7.2.28-2.1build2
- 7.2.28-2.1build3
- 7.2.28-2.1build4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ipe Ubuntu:25.10
- Versions
- 7.2.30-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ipe Ubuntu:26.10
- Versions
- 7.2.30-1build2
- 7.2.30-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ipe Ubuntu:26.04:LTS
- Versions
- 7.2.30-1build1
- 7.2.30-1build2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- http://lists.fedoraproject.org/pipermail/package-announce/2010-November/050285.html
- http://www.openwall.com/lists/oss-security/2010/10/04/6
- http://lists.fedoraproject.org/pipermail/package-announce/2010-October/049392.html
- http://www.redhat.com/support/errata/RHSA-2010-0859.html
- http://secunia.com/advisories/42357
- http://www.mandriva.com/security/advisories?name=MDVSA-2010:228
- http://www.vupen.com/english/advisories/2011/0230
- http://www.redhat.com/support/errata/RHSA-2010-0752.html
- http://www.openoffice.org/security/cves/CVE-2010-3702_CVE-2010-3704.html
- https://bugzilla.redhat.com/show_bug.cgi?id=638960
- http://www.mandriva.com/security/advisories?name=MDVSA-2010:230
- http://lists.opensuse.org/opensuse-security-announce/2010-11/msg00006.html
- http://cgit.freedesktop.org/poppler/poppler/commit/?id=39d140bfc0b8239bdd96d6a55842034ae5c05473
- http://rhn.redhat.com/errata/RHSA-2012-1201.html
- http://www.mandriva.com/security/advisories?name=MDVSA-2010:231
- http://lists.fedoraproject.org/pipermail/package-announce/2010-November/050390.html
- http://slackware.com/security/viewer.php?l=slackware-security&y=2010&m=slackware-security.571720
- http://www.redhat.com/support/errata/RHSA-2010-0751.html
- http://secunia.com/advisories/42397
- http://secunia.com/advisories/42141
- http://lists.fedoraproject.org/pipermail/package-announce/2010-October/049523.html
- http://www.mandriva.com/security/advisories?name=MDVSA-2012:144
- http://www.vupen.com/english/advisories/2010/3097
- https://nvd.nist.gov/vuln/detail/CVE-2010-3704