p PatchFirst

CVE-2010-4008

CVE-2010-4008

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

libxml2 before 2.7.8, as used in Google Chrome before 7.0.517.44, Apple Safari 5.0.2 and earlier, and other products, reads from invalid memory locations during processing of malformed XPath expressions, which allows context-dependent attackers to cause a denial of service (application crash) via a crafted XML document.

EPSS 2.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libxml2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.7.8.dfsg-1

    Update to 2.7.8.dfsg-1

  • libxml2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.7.8.dfsg-1

    Update to 2.7.8.dfsg-1

  • libxml2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.7.8.dfsg-1

    Update to 2.7.8.dfsg-1

Original sources

Check your server →