p PatchFirst

CVE-2010-4300

CVE-2010-4300

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Heap-based buffer overflow in the dissect_ldss_transfer function (epan/dissectors/packet-ldss.c) in the LDSS dissector in Wireshark 1.2.0 through 1.2.12 and 1.4.0 through 1.4.1 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via an LDSS packet with a long digest line that triggers memory corruption.

EPSS 13.8% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wireshark Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.2.11-4

    Update to 1.2.11-4

  • wireshark Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.2.11-4

    Update to 1.2.11-4

  • wireshark Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.2.11-4

    Update to 1.2.11-4

Original sources

Check your server →