p PatchFirst

CVE-2011-0446

CVE-2011-0446

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple cross-site scripting (XSS) vulnerabilities in the mail_to helper in Ruby on Rails before 2.3.11, and 3.x before 3.0.4, when javascript encoding is used, allow remote attackers to inject arbitrary web script or HTML via a crafted (1) name or (2) email value.

EPSS 2.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rails Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.3.11-0.1

    Update to 2.3.11-0.1

  • rails Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.3.11-0.1

    Update to 2.3.11-0.1

  • rails Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.3.11-0.1

    Update to 2.3.11-0.1

Original sources

Check your server →