p PatchFirst

CVE-2011-0447

CVE-2011-0447

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Ruby on Rails 2.1.x, 2.2.x, and 2.3.x before 2.3.11, and 3.x before 3.0.4, does not properly validate HTTP requests that contain an X-Requested-With header, which makes it easier for remote attackers to conduct cross-site request forgery (CSRF) attacks via forged (1) AJAX or (2) API requests that leverage "combinations of browser plugins and HTTP redirects," a related issue to CVE-2011-0696.

EPSS 1.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rails Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.3.11-0.1

    Update to 2.3.11-0.1

  • rails Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.3.11-0.1

    Update to 2.3.11-0.1

  • rails Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.3.11-0.1

    Update to 2.3.11-0.1

Original sources

Check your server →