p PatchFirst

CVE-2011-0696

CVE-2011-0696

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Django 1.1.x before 1.1.4 and 1.2.x before 1.2.5 does not properly validate HTTP requests that contain an X-Requested-With header, which makes it easier for remote attackers to conduct cross-site request forgery (CSRF) attacks via forged AJAX requests that leverage a "combination of browser plugins and redirects," a related issue to CVE-2011-0447.

CVSS 8.2 · High · EPSS 1.6% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • python-django Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.2.5-1

    Update to 1.2.5-1

  • python-django Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.2.5-1

    Update to 1.2.5-1

  • python-django Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.2.5-1

    Update to 1.2.5-1

  • django PyPI

    Versions
    • 1.1
    • 1.1.1
    • 1.1.2
    • 1.1.3
    Affected ranges
    • ECOSYSTEM: ≥ 1.1, < 1.1.4

    Update to 1.1.4

  • django PyPI

    Versions
    • 1.2
    • 1.2.1
    • 1.2.2
    • 1.2.3
    • 1.2.4
    Affected ranges
    • ECOSYSTEM: ≥ 1.2, < 1.2.5

    Update to 1.2.5

  • django PyPI

    Versions
    • 1.1
    • 1.1.1
    • 1.1.2
    • 1.1.3
    • 1.2
    • 1.2.1
    • 1.2.2
    • 1.2.3
    • 1.2.4
    Affected ranges
    • ECOSYSTEM: ≥ 1.1, < 1.1.4 ∪ ≥ 1.2, < 1.2.5

    Update to 1.1.4; Update to 1.2.5

Original sources

Check your server →