p PatchFirst

CVE-2011-1522

CVE-2011-1522

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple SQL injection vulnerabilities in the Doctrine\DBAL\Platforms\AbstractPlatform::modifyLimitQuery function in Doctrine 1.x before 1.2.4 and 2.x before 2.0.3 allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset field.

EPSS 2.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • doctrine Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.2.4-1

    Update to 1.2.4-1

  • doctrine Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.2.4-1

    Update to 1.2.4-1

  • doctrine Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.2.4-1

    Update to 1.2.4-1

Original sources

Check your server →