p PatchFirst

CVE-2011-1578

CVE-2011-1578

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.3, when Internet Explorer 6 or earlier is used, allows remote attackers to inject arbitrary web script or HTML via an uploaded file accessed with a dangerous extension such as .html at the end of the query string, in conjunction with a modified URI path that has a %2E sequence in place of the . (dot) character.

EPSS 2.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • mediawiki Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:1.15.5-5

    Update to 1:1.15.5-5

  • mediawiki Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:1.15.5-5

    Update to 1:1.15.5-5

  • mediawiki Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:1.15.5-5

    Update to 1:1.15.5-5

Original sources

Check your server →