p PatchFirst

CVE-2011-1590

CVE-2011-1590

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The X.509if dissector in Wireshark 1.2.x before 1.2.16 and 1.4.x before 1.4.5 does not properly initialize certain global variables, which allows remote attackers to cause a denial of service (application crash) via a crafted .pcap file.

EPSS 1.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wireshark Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.4.5-1

    Update to 1.4.5-1

  • wireshark Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.4.5-1

    Update to 1.4.5-1

  • wireshark Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.4.5-1

    Update to 1.4.5-1

Original sources

Check your server →