p PatchFirst

CVE-2011-2506

CVE-2011-2506

This page contains facts from public vulnerability sources. Check the original advisory before updating.

setup/lib/ConfigGenerator.class.php in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 does not properly restrict the presence of comment closing delimiters, which allows remote attackers to conduct static code injection attacks by leveraging the ability to modify the SESSION superglobal array.

EPSS 9.6% · Public exploit · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • phpmyadmin Debian:12

    Affected ranges
    • ECOSYSTEM: < 4:3.4.3.1-1

    Update to 4:3.4.3.1-1

  • phpmyadmin Debian:13

    Affected ranges
    • ECOSYSTEM: < 4:3.4.3.1-1

    Update to 4:3.4.3.1-1

  • phpmyadmin Debian:14

    Affected ranges
    • ECOSYSTEM: < 4:3.4.3.1-1

    Update to 4:3.4.3.1-1

  • phpmyadmin/phpmyadmin Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 3.0, < 3.3.10.2

    Update to 3.3.10.2

  • phpmyadmin/phpmyadmin Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 3.4, < 3.4.3.1

    Update to 3.4.3.1

Original sources

Check your server →