p PatchFirst

CVE-2011-2507

CVE-2011-2507

This page contains facts from public vulnerability sources. Check the original advisory before updating.

libraries/server_synchronize.lib.php in the Synchronize implementation in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 does not properly quote regular expressions, which allows remote authenticated users to inject a PCRE e (aka PREG_REPLACE_EVAL) modifier, and consequently execute arbitrary PHP code, by leveraging the ability to modify the SESSION superglobal array.

EPSS 3.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • phpmyadmin Debian:12

    Affected ranges
    • ECOSYSTEM: < 4:3.4.3.1-1

    Update to 4:3.4.3.1-1

  • phpmyadmin Debian:13

    Affected ranges
    • ECOSYSTEM: < 4:3.4.3.1-1

    Update to 4:3.4.3.1-1

  • phpmyadmin Debian:14

    Affected ranges
    • ECOSYSTEM: < 4:3.4.3.1-1

    Update to 4:3.4.3.1-1

Original sources

Check your server →