CVE-2011-2509
CVE-2011-2509
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Multiple cross-site scripting (XSS) vulnerabilities in Joomla! before 1.6.4 allow remote attackers to inject arbitrary web script or HTML via (1) the query string to the com_contact component, as demonstrated by the Itemid parameter to index.php; (2) the query string to the com_content component, as demonstrated by the filter_order parameter to index.php; (3) the query string to the com_newsfeeds component, as demonstrated by an arbitrary parameter to index.php; or (4) the option parameter in a reset.request action to index.php; and, when Internet Explorer or Konqueror is used, (5) allow remote attackers to inject arbitrary web script or HTML via the searchword parameter in a search action to index.php in the com_search component.
CVSS 5.3 · Medium · EPSS 1.1% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
joomla/joomla-cms Packagist
- Affected ranges
- ECOSYSTEM: < 1.6.4
Update to 1.6.4
Original sources
- http://yehg.net/lab/pr0js/advisories/joomla/core/%5Bjoomla_1.6.3%5D_cross_site_scripting%28XSS%29
- http://www.openwall.com/lists/oss-security/2011/06/28/4
- http://developer.joomla.org/security/news/352-20110604-xss-vulnerability.html
- http://www.openwall.com/lists/oss-security/2011/06/29/12
- https://nvd.nist.gov/vuln/detail/CVE-2011-2509