p PatchFirst

CVE-2011-2511

CVE-2011-2511

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Integer overflow in libvirt before 0.9.3 allows remote authenticated users to cause a denial of service (libvirtd crash) and possibly execute arbitrary code via a crafted VirDomainGetVcpus RPC call that triggers memory corruption.

EPSS 3.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libvirt Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.9.2-7

    Update to 0.9.2-7

  • libvirt Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.9.2-7

    Update to 0.9.2-7

  • libvirt Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.9.2-7

    Update to 0.9.2-7

Original sources

Check your server →