p PatchFirst

CVE-2011-2931

CVE-2011-2931

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in the strip_tags helper in actionpack/lib/action_controller/vendor/html-scanner/html/node.rb in Ruby on Rails before 2.3.13, 3.0.x before 3.0.10, and 3.1.x before 3.1.0.rc5 allows remote attackers to inject arbitrary web script or HTML via a tag with an invalid name.

EPSS 2.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rails Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.3.14

    Update to 2.3.14

  • rails Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.3.14

    Update to 2.3.14

  • rails Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.3.14

    Update to 2.3.14

Original sources

Check your server →