p PatchFirst

CVE-2011-3378

CVE-2011-3378

This page contains facts from public vulnerability sources. Check the original advisory before updating.

RPM 4.4.x through 4.9.x, probably before 4.9.1.2, allows remote attackers to cause a denial of service (memory corruption) and possibly execute arbitrary code via an rpm package with crafted headers and offsets that are not properly handled when a package is queried or installed, related to (1) the regionSwab function, (2) the headerLoad function, and (3) multiple functions in rpmio/rpmpgp.c.

EPSS 5.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rpm Debian:12

    Affected ranges
    • ECOSYSTEM: < 4.9.1.2-1

    Update to 4.9.1.2-1

  • rpm Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.9.1.2-1

    Update to 4.9.1.2-1

  • rpm Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.9.1.2-1

    Update to 4.9.1.2-1

Original sources

Check your server →