p PatchFirst

CVE-2011-3607

CVE-2011-3607

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Integer overflow in the ap_pregsub function in server/util.c in the Apache HTTP Server 2.0.x through 2.0.64 and 2.2.x through 2.2.21, when the mod_setenvif module is enabled, allows local users to gain privileges via a .htaccess file with a crafted SetEnvIf directive, in conjunction with a crafted HTTP request header, leading to a heap-based buffer overflow.

EPSS 4.7% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • apache2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.2.21-4

    Update to 2.2.21-4

  • apache2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.2.21-4

    Update to 2.2.21-4

  • apache2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.2.21-4

    Update to 2.2.21-4

Original sources

Check your server →