CVE-2011-4111
CVE-2011-4111
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Buffer overflow in the ccid_card_vscard_handle_message function in hw/ccid-card-passthru.c in QEMU before 0.15.2 and 1.x before 1.0-rc4 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted VSC_ATR message.
EPSS 2.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
qemu Debian:12
- Affected ranges
- ECOSYSTEM: < 0.15.1+dfsg-2
Update to 0.15.1+dfsg-2
qemu Debian:13
- Affected ranges
- ECOSYSTEM: < 0.15.1+dfsg-2
Update to 0.15.1+dfsg-2
qemu Debian:14
- Affected ranges
- ECOSYSTEM: < 0.15.1+dfsg-2
Update to 0.15.1+dfsg-2
xen Debian:12
- Affected ranges
- ECOSYSTEM: < 4.4.0-1
Update to 4.4.0-1
xen Debian:13
- Affected ranges
- ECOSYSTEM: < 4.4.0-1
Update to 4.4.0-1
xen Debian:14
- Affected ranges
- ECOSYSTEM: < 4.4.0-1
Update to 4.4.0-1
Original sources
- https://bugzilla.redhat.com/show_bug.cgi?id=751310
- http://git.qemu.org/?p=qemu-stable-0.15.git%3Ba=log
- http://git.qemu.org/?p=qemu.git%3Ba=log%3Bh=refs/heads/stable-1.0
- http://rhn.redhat.com/errata/RHSA-2011-1777.html
- http://rhn.redhat.com/errata/RHSA-2011-1801.html
- https://nvd.nist.gov/vuln/detail/CVE-2011-4111