p PatchFirst

CVE-2011-4415

CVE-2011-4415

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The ap_pregsub function in server/util.c in the Apache HTTP Server 2.0.x through 2.0.64 and 2.2.x through 2.2.21, when the mod_setenvif module is enabled, does not restrict the size of values of environment variables, which allows local users to cause a denial of service (memory consumption or NULL pointer dereference) via a .htaccess file with a crafted SetEnvIf directive, in conjunction with a crafted HTTP request header, related to (1) the "len +=" statement and (2) the apr_pcalloc function call, a different vulnerability than CVE-2011-3607.

EPSS 3.0% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • apache2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.4.1-1

    Update to 2.4.1-1

  • apache2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.4.1-1

    Update to 2.4.1-1

  • apache2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.4.1-1

    Update to 2.4.1-1

Original sources

Check your server →