p PatchFirst

CVE-2011-4579

CVE-2011-4579

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The svq1_decode_frame function in the SVQ1 decoder (svq1dec.c) in libavcodec in FFmpeg 0.5.x before 0.5.7, 0.6.x before 0.6.4, 0.7.x before 0.7.9, and 0.8.x before 0.8.8; and in Libav 0.5.x before 0.5.6, 0.6.x before 0.6.4, and 0.7.x before 0.7.3 allows remote attackers to cause a denial of service (memory corruption) via a crafted SVQ1 stream, related to "dimensions changed."

EPSS 3.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ffmpeg Debian:12

    Affected ranges
    • ECOSYSTEM: < 7:2.4.1-1

    Update to 7:2.4.1-1

  • ffmpeg Debian:13

    Affected ranges
    • ECOSYSTEM: < 7:2.4.1-1

    Update to 7:2.4.1-1

  • ffmpeg Debian:14

    Affected ranges
    • ECOSYSTEM: < 7:2.4.1-1

    Update to 7:2.4.1-1

Original sources

Check your server →