p PatchFirst

CVE-2011-4957

CVE-2011-4957

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The make_clickable function in wp-includes/formatting.php in WordPress before 3.1.1 does not properly check URLs before passing them to the PCRE library, which allows remote attackers to cause a denial of service (crash) via a comment with a crafted URL that triggers many recursive calls.

EPSS 3.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wordpress Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.2.1+dfsg-1

    Update to 3.2.1+dfsg-1

  • wordpress Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.2.1+dfsg-1

    Update to 3.2.1+dfsg-1

  • wordpress Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.2.1+dfsg-1

    Update to 3.2.1+dfsg-1

Original sources

Check your server →