p PatchFirst

CVE-2012-0042

CVE-2012-0042

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Wireshark 1.4.x before 1.4.11 and 1.6.x before 1.6.5 does not properly perform certain string conversions, which allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted packet, related to epan/to_str.c.

EPSS 1.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wireshark Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.6.5-1

    Update to 1.6.5-1

  • wireshark Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.6.5-1

    Update to 1.6.5-1

  • wireshark Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.6.5-1

    Update to 1.6.5-1

Original sources

Check your server →