p PatchFirst

CVE-2012-1098

CVE-2012-1098

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving a SafeBuffer object that is manipulated through certain methods.

EPSS 2.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rails Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.3.14

    Update to 2.3.14

  • rails Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.3.14

    Update to 2.3.14

  • rails Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.3.14

    Update to 2.3.14

Original sources

Check your server →