p PatchFirst

CVE-2012-1099

CVE-2012-1099

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/form_options_helper.rb in the select helper in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving certain generation of OPTION elements within SELECT elements.

EPSS 2.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rails Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.3.14

    Update to 2.3.14

  • rails Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.3.14

    Update to 2.3.14

  • rails Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.3.14

    Update to 2.3.14

Original sources

Check your server →