CVE-2012-1157
CVE-2012-1157
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Moodle before 2.2.2 has a default repository capabilities issue where all repositories are viewable by all users by default
CVSS 4.3 · Medium · EPSS 1.2% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
moodle
- Versions
- 2.2 to 2.2.1+: Affected
- 2.1 to 2.1.4+: Affected
- 2.0 to 2.0.7+: Affected
No fix published
moodle/moodle Packagist
- Affected ranges
- ECOSYSTEM: ≥ 2.2, < 2.2.2
Update to 2.2.2
moodle/moodle Packagist
- Affected ranges
- ECOSYSTEM: ≥ 2.1, < 2.1.5
Update to 2.1.5
moodle/moodle Packagist
- Affected ranges
- ECOSYSTEM: ≥ 2.0, < 2.0.8
Update to 2.0.8
moodle/moodle Packagist
- Affected ranges
- ECOSYSTEM: < 1.9.17
Update to 1.9.17
Original sources
- http://lists.fedoraproject.org/pipermail/package-announce/2012-April/078209.html
- https://security-tracker.debian.org/tracker/CVE-2012-1157
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2012-1157
- https://access.redhat.com/security/cve/cve-2012-1157
- http://lists.fedoraproject.org/pipermail/package-announce/2012-May/081047.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-April/078210.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-April/077635.html
- http://lists.fedoraproject.org/pipermail/package-announce/2012-May/080712.html
- https://moodle.org/mod/forum/discuss.php?d=198624
- https://nvd.nist.gov/vuln/detail/CVE-2012-1157