p PatchFirst

CVE-2012-1573

CVE-2012-1573

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

gnutls_cipher.c in libgnutls in GnuTLS before 2.12.17 and 3.x before 3.0.15 does not properly handle data encrypted with a block cipher, which allows remote attackers to cause a denial of service (heap memory corruption and application crash) via a crafted record, as demonstrated by a crafted GenericBlockCipher structure.

EPSS 4.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gnutls28 Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.0.17-2

    Update to 3.0.17-2

  • gnutls28 Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.0.17-2

    Update to 3.0.17-2

  • gnutls28 Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.0.17-2

    Update to 3.0.17-2

Original sources

Check your server →