p PatchFirst

CVE-2012-1582

CVE-2012-1582

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in the wikitext parser in MediaWiki 1.17.x before 1.17.3 and 1.18.x before 1.18.2 allows remote attackers to inject arbitrary web script or HTML via a crafted page with "forged strip item markers," as demonstrated using the CharInsert extension.

EPSS 2.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • mediawiki Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:1.15.5-9

    Update to 1:1.15.5-9

  • mediawiki Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:1.15.5-9

    Update to 1:1.15.5-9

  • mediawiki Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:1.15.5-9

    Update to 1:1.15.5-9

Original sources

Check your server →