p PatchFirst

CVE-2012-1608

CVE-2012-1608

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The t3lib_div::RemoveXSS API method in TYPO3 4.4.0 through 4.4.13, 4.5.0 through 4.5.13, 4.6.0 through 4.6.6, 4.7, and 6.0 allows remote attackers to bypass the cross-site scripting (XSS) protection mechanism and inject arbitrary web script or HTML via non printable characters.

EPSS 2.3% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • typo3/cms Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 4.4.0, < 4.4.14

    Update to 4.4.14

  • typo3/cms Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 4.5.0, < 4.5.14

    Update to 4.5.14

  • typo3/cms Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 4.6.0, < 4.6.7

    Update to 4.6.7

Original sources

Check your server →