p PatchFirst

CVE-2012-2094

CVE-2012-2094

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in the refresh mechanism in the log viewer in horizon/static/horizon/js/horizon.js in OpenStack Dashboard (Horizon) folsom-1 and 2012.1 and earlier allows remote attackers to inject arbitrary web script or HTML via the guest console.

EPSS 2.4% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • horizon Debian:12

    Affected ranges
    • ECOSYSTEM: < 2012.1-3

    Update to 2012.1-3

  • horizon Debian:13

    Affected ranges
    • ECOSYSTEM: < 2012.1-3

    Update to 2012.1-3

  • horizon Debian:14

    Affected ranges
    • ECOSYSTEM: < 2012.1-3

    Update to 2012.1-3

  • horizon PyPI

    Affected ranges
    • ECOSYSTEM: < 8.0.0a0

    Update to 8.0.0a0

Original sources

Check your server →