CVE-2012-2126
CVE-2012-2126
This page contains facts from public vulnerability sources. Check the original advisory before updating.
RubyGems before 1.8.23 does not verify an SSL certificate, which allows remote attackers to modify a gem during installation via a man-in-the-middle attack.
EPSS 1.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
rubygems Debian:12
- Affected ranges
- ECOSYSTEM: < 1.8.24-1
Update to 1.8.24-1
rubygems Debian:13
- Affected ranges
- ECOSYSTEM: < 1.8.24-1
Update to 1.8.24-1
rubygems Debian:14
- Affected ranges
- ECOSYSTEM: < 1.8.24-1
Update to 1.8.24-1
jruby Ubuntu:Pro:14.04:LTS
- Versions
- 1.5.6-5ubuntu1
- 1.5.6-6
- 1.5.6-7
- 1.5.6-9+deb8u2build0.14.04.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- http://secunia.com/advisories/55381
- http://www.ubuntu.com/usn/USN-1582-1/
- https://github.com/rubygems/rubygems/blob/1.8/History.txt
- http://rhn.redhat.com/errata/RHSA-2013-1203.html
- https://bugzilla.redhat.com/show_bug.cgi?id=814718
- http://www.openwall.com/lists/oss-security/2012/04/20/24
- http://rhn.redhat.com/errata/RHSA-2013-1852.html
- http://rhn.redhat.com/errata/RHSA-2013-1441.html
- https://nvd.nist.gov/vuln/detail/CVE-2012-2126