p PatchFirst

CVE-2012-2140

CVE-2012-2140

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The Mail gem before 2.4.3 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a (1) sendmail or (2) exim delivery.

EPSS 4.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ruby-mail Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.4.4-1

    Update to 2.4.4-1

  • ruby-mail Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.4.4-1

    Update to 2.4.4-1

  • ruby-mail Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.4.4-1

    Update to 2.4.4-1

Original sources

Check your server →