CVE-2012-2388
CVE-2012-2388
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The GMP Plugin in strongSwan 4.2.0 through 4.6.3 allows remote attackers to bypass authentication via a (1) empty or (2) zeroed RSA signature, aka "RSA signature verification vulnerability."
EPSS 3.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
strongswan Debian:12
- Affected ranges
- ECOSYSTEM: < 4.5.2-1.4
Update to 4.5.2-1.4
strongswan Debian:13
- Affected ranges
- ECOSYSTEM: < 4.5.2-1.4
Update to 4.5.2-1.4
strongswan Debian:14
- Affected ranges
- ECOSYSTEM: < 4.5.2-1.4
Update to 4.5.2-1.4
Original sources
- https://exchange.xforce.ibmcloud.com/vulnerabilities/76013
- http://www.securitytracker.com/id?1027110
- http://osvdb.org/82587
- http://secunia.com/advisories/49336
- http://secunia.com/advisories/49315
- http://www.securityfocus.com/bid/53752
- http://www.strongswan.org/blog/2012/05/31/strongswan-4.6.4-released-%28cve-2012-2388%29.html
- http://lists.opensuse.org/opensuse-security-announce/2012-06/msg00002.html
- http://secunia.com/advisories/55051
- http://secunia.com/advisories/49370
- http://www.debian.org/security/2012/dsa-2483
- https://nvd.nist.gov/vuln/detail/CVE-2012-2388