p PatchFirst

CVE-2012-2687

CVE-2012-2687

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Multiple cross-site scripting (XSS) vulnerabilities in the make_variant_list function in mod_negotiation.c in the mod_negotiation module in the Apache HTTP Server 2.4.x before 2.4.3, when the MultiViews option is enabled, allow remote attackers to inject arbitrary web script or HTML via a crafted filename that is not properly handled during construction of a variant list.

EPSS 22.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • apache2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.2.22-8

    Update to 2.2.22-8

  • apache2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.2.22-8

    Update to 2.2.22-8

  • apache2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.2.22-8

    Update to 2.2.22-8

Original sources

Check your server →