p PatchFirst

CVE-2012-2698

CVE-2012-2698

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in the outputPage function in includes/SkinTemplate.php in MediaWiki before 1.17.5, 1.18.x before 1.18.4, and 1.19.x before 1.19.1 allows remote attackers to inject arbitrary web script or HTML via the uselang parameter to index.php/Main_page.

EPSS 4.9% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • mediawiki Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:1.19.1-1

    Update to 1:1.19.1-1

  • mediawiki Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:1.19.1-1

    Update to 1:1.19.1-1

  • mediawiki Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:1.19.1-1

    Update to 1:1.19.1-1

Original sources

Check your server →