p PatchFirst

CVE-2012-3402

CVE-2012-3402

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Integer overflow in plug-ins/common/psd.c in the Adobe Photoshop PSD plugin in GIMP 2.2.13 and earlier allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted channels header value in a PSD image file, which triggers a heap-based buffer overflow, a different vulnerability than CVE-2009-3909.

EPSS 4.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gimp Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.4.0~rc1-1

    Update to 2.4.0~rc1-1

  • gimp Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.4.0~rc1-1

    Update to 2.4.0~rc1-1

  • gimp Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.4.0~rc1-1

    Update to 2.4.0~rc1-1

Original sources

Check your server →