p PatchFirst

CVE-2012-3464

CVE-2012-3464

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in activesupport/lib/active_support/core_ext/string/output_safety.rb in Ruby on Rails before 3.0.17, 3.1.x before 3.1.8, and 3.2.x before 3.2.8 might allow remote attackers to inject arbitrary web script or HTML via vectors involving a ' (quote) character.

EPSS 2.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rails Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.3.14.1

    Update to 2.3.14.1

  • rails Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.3.14.1

    Update to 2.3.14.1

  • rails Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.3.14.1

    Update to 2.3.14.1

Original sources

Check your server →