p PatchFirst

CVE-2012-3465

CVE-2012-3465

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/sanitize_helper.rb in the strip_tags helper in Ruby on Rails before 3.0.17, 3.1.x before 3.1.8, and 3.2.x before 3.2.8 allows remote attackers to inject arbitrary web script or HTML via malformed HTML markup.

EPSS 2.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rails Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.3.14.1

    Update to 2.3.14.1

  • rails Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.3.14.1

    Update to 2.3.14.1

  • rails Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.3.14.1

    Update to 2.3.14.1

Original sources

Check your server →