p PatchFirst

CVE-2012-4277

CVE-2012-4277

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in the smarty_function_html_options_optoutput function in distribution/libs/plugins/function.html_options.php in Smarty before 3.1.8 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

EPSS 1.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • smarty3 Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.1.10-1

    Update to 3.1.10-1

  • smarty3 Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.1.10-1

    Update to 3.1.10-1

  • smarty3 Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.1.10-1

    Update to 3.1.10-1

Original sources

Check your server →