p PatchFirst

CVE-2012-4437

CVE-2012-4437

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in the SmartyException class in Smarty (aka smarty-php) before 3.1.12 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors that trigger a Smarty exception.

EPSS 2.5% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • smarty3 Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.1.10-2

    Update to 3.1.10-2

  • smarty3 Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.1.10-2

    Update to 3.1.10-2

  • smarty3 Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.1.10-2

    Update to 3.1.10-2

  • smarty/smarty Packagist

    Versions
    • v2.6.24
    • v2.6.25
    • v2.6.26
    • v2.6.27
    • v2.6.28
    • v2.6.29
    • v2.6.30
    • v2.6.31
    • v2.6.33
    • v3.1.11
    Affected ranges
    • ECOSYSTEM: < 3.1.12

    Update to 3.1.12

Original sources

Check your server →