CVE-2012-4751
CVE-2012-4751
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Cross-site scripting (XSS) vulnerability in Open Ticket Request System (OTRS) Help Desk 2.4.x before 2.4.15, 3.0.x before 3.0.17, and 3.1.x before 3.1.11 allows remote attackers to inject arbitrary web script or HTML via an e-mail message body with whitespace before a javascript: URL in the SRC attribute of an element, as demonstrated by an IFRAME element.
EPSS 5.8% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
otrs2 Debian:11
- Versions
- 2.0.4p01-10
- 2.0.4p01-11
- 2.0.4p01-12
- 2.0.4p01-13
- 2.0.4p01-14
- 2.0.4p01-14.1
- 2.0.4p01-15
- 2.0.4p01-16
- 2.0.4p01-17
- 2.0.4p01-18
- 2.0.4p01-6
- 2.0.4p01-7
- 2.0.4p01-8
- 2.0.4p01-9
- 2.0.99beta1-1
- 2.0.99beta1-2
- 2.1.1-1
- 2.1.3-1
- 2.1.4-1
- 2.1.4-2
- 2.1.5-1
- 2.1.5-2
- 2.1.5-3
- 2.1.6-1
- 2.1.7-1
- 2.1.7-2
- 2.2.0~beta2-1
- 2.2.0~beta3-1
- 2.2.1-1
- 2.2.2-1
- 2.2.3-1
- 2.2.4-1
- 2.2.5-1
- 2.2.5-2
- 2.2.6-1
- 2.2.7-1
- 2.2.7-2
- 2.2.7-2lenny1
- 2.2.7-2lenny2
- 2.2.7-2lenny3
- 2.2.7-3
- 2.3.2-1
- 2.3.2-2
- 2.3.3-1
- 2.3.4-1
- 2.3.4-2
- 2.3.4-3
- 2.3.4-4
- 2.3.4-5
- 2.3.4-6
- 2.3.4-7
- 2.4.10+dfsg1-1
- 2.4.10+dfsg1-2
- 2.4.10+dfsg1-3
- 2.4.5-1
- 2.4.5-2
- 2.4.5-3
- 2.4.5-4
- 2.4.5-5
- 2.4.6-1
- 2.4.6-2
- 2.4.7+dfsg1-1
- 2.4.7-1
- 2.4.7-2
- 2.4.7-3
- 2.4.7-4
- 2.4.7-5
- 2.4.7-6
- 2.4.8+dfsg1-1
- 2.4.9+dfsg1-1
- 2.4.9+dfsg1-2
- 2.4.9+dfsg1-3
- 2.4.9+dfsg1-3+squeeze1
- 2.4.9+dfsg1-3+squeeze3
- 2.4.9+dfsg1-3+squeeze4
- 2.4.9+dfsg1-3+squeeze5
- 2.4.9+dfsg1-4
- 2.4.9+dfsg1-5
- 3.0.10+dfsg1-1
- 3.0.10+dfsg1-2
- 3.0.11+dfsg1-1
- 3.0.8+dfsg1-1
- 3.0.9+dfsg1-1
- 3.1.0~beta4+dfsg1-1
- 3.1.0~beta5+dfsg1-1
- 3.1.0~rc1+dfsg1-1
- 3.1.1+dfsg1-1
- 3.1.1+dfsg1-2
- 3.1.2+dfsg1-1
- 3.1.2+dfsg1-2
- 3.1.2+dfsg1-3
- 3.1.3+dfsg1-1
- 3.1.3+dfsg1-2
- 3.1.4+dfsg1-1
- 3.1.5+dfsg1-1
- 3.1.5+dfsg1-2
- 3.1.5+dfsg1-3
- 3.1.6+dfsg1-1
- 3.1.7+dfsg1-1
- 3.1.7+dfsg1-2
- 3.1.7+dfsg1-3
- 3.1.7+dfsg1-4
- 3.1.7+dfsg1-5
- Affected ranges
- ECOSYSTEM: < 3.1.7+dfsg1-6
Update to 3.1.7+dfsg1-6
Original sources
- http://lists.opensuse.org/opensuse-updates/2013-01/msg00036.html
- http://www.securityfocus.com/bid/56093
- http://znuny.com/assets/proof_of_concept_cve_2012-4751-znuny.py
- http://www.otrs.com/en/open-source/community-news/security-advisories/security-advisory-2012-03/
- http://znuny.com/en/#%21/advisory/ZSA-2012-03
- http://www.kb.cert.org/vuls/id/603276
- http://packetstormsecurity.org/files/117504/OTRS-3.1-Cross-Site-Scripting.html
- https://nvd.nist.gov/vuln/detail/CVE-2012-4751